Shell Upload RCE (CVE-2015-8562) Joomla 3.4.6 – 5.6.13 Vulnerable to Attack – Video PoC

By | January 23, 2016

A critical remote code execution(RCE) vulnerability was discovered in Joomla! websites. This is making a lot of noise because of the following reasons.

  1. It appears that attackers started exploiting this even before the disclosure(0-day).
  2. It is very easy to exploit this vulnerability.
  3. Almost all the versions of Joomla are vulnerable under with certain conditions.

At its core, this is an input validation issue. An attacker can inject arbitrary input using the X-FORWARDED-FOR or User-Agent header to attack this vulnerabilty without showing up in webserver logs! The only way to detect this is with Snort or Network IDS/IPS capabilities and yes, they can achieve code execution.

All versions of the Joomla! below 3.4.6 are known to be vulnerable. But exploitation is possible with PHP versions below 5.5.29, 5.6.13 and below 5.5.

 

 

Share Button